升级WordPress网站PHP7.2新版本本的留意事宜

摘要:许多WordPress老网站,一直沒有升级WordPress程序或是仍在应用两年前的WordPress主题风格和软件。...

许多WordPress老网站,一直沒有升级WordPress程序或是仍在应用两年前的WordPress主题风格和软件。

这种WordPress主题风格和软件十分历史悠久,许多创作者早已舍弃了升级,例如很知名的强烈推荐VPS服务器服务的老左blog的WordPress主题风格,也有大前天强烈推荐大前天十年沒有升级的Spider Tracker WordPress软件。

许多出色的WordPress主题风格和软件只有适用低版本号的WordPress程序和PHP版本号。如果对WordPress程序开展升級,这针对这种网站的创作者来讲,那就是十分繁杂的,费时间费劲。

WordPress官方网在2020年前些情况下早已公布WordPress新版本本程序已不适用PHP 5.6.2下列版本号。

这一情况下就遭遇费时间费劲和低版本号WordPress程序安全性性没法确保中间作出选择。

无论再难,提议升級……2020年周边许多做WordPress网站的朋友早已被侵入,经验教训是惨重的。

在升級的情况下要留意下列几个方面。

1、求新不求旧,最少版本号提议PHP7.2

现阶段PHP5.6.2十分平稳,并且官方网也仍在适用。可是因为是WordPress程序最少适用PHP版本号。保参差不齐何时也不再适用这一版本号。

假如你的WordPress网站,由于说白了的平稳性,适用这一低版本号,一旦官方网已不适用,你又要对WordPress网站主题风格、软件還是网络服务器扩展再做调节,简直十分不便。

PHP7历经一一段时间的提升迭代更新,PHP7系列产品版本号有更强的实行高效率和安全性性,现阶段全新的版本号为PHP7.3.5,自己的英语站speechwiki早已适用到这一版本号。PHP7.3.5关键是在安全性性上作出了提升。

2、数据信息最大要,搞好备份数据

在WordPress程序和PHP7.2版本号升級以前,全方位排查WordPress主题风格和软件有木有开展适配性升级,这一能够在软件安裝网页页面开展查询。假如长期不升级,提议慎用,非常是很多大版本号无升级的,用用还好,长期性开启就会有安全性难题。

WordPress主题风格长期性不升级,涵数早已有十分大的调节,PHP升級后,WordPress主题风格或许会没法一切正常应用,但是从现阶段看来这类状况十分少。

3、网络服务器扩展软件还要适配性查验

假如你的WordPress网站应用的虚似服务器,必须联络服务器商。由于虚似服务器管理权限是服务器商管理方法。假如服务器商的PHP版本号较为低且没法升級,提议舍弃或是用完后也不要续签了。

VPS网络服务器假如用的是宝塔面板控制面板,立即升級PHP就可以。以下图所显示:

假如应用的是LNMP/LAMP/Onestacks一键脚本制作,找各有官方网升級方式。(接着找一下每个脚本制作PHP升級方式,下一次升级)

PHP版本号升級以后,查询PHP扩展有木有一切正常工作中,也有要查验一下WordPress后台管理的PHP扩展软件的版本号有木有太低、是否会存有适配性的问题,例如Redis的WordPress软件Redis Object Cache版本号是不是适用你的WordPress网站PHP版本号。

WordPress网站源代码和PHP版本号升級以后,把主页,文章内容页,也有每个网页页面都浏览一下,一切正常得话,就升級取得成功了。

WordPress程序升級還是十分良知的,即使是那么很多年那么经常的升級,都没有说成摆甚么幺蛾子,也是有遵照自身一直至今的升級逻辑性。



联系我们

全国服务热线:4000-399-000 公司邮箱:343111187@qq.com

  工作日 9:00-18:00

关注我们

官网公众号

官网公众号

Copyright?2020 广州凡科互联网科技股份有限公司 版权所有 粤ICP备10235580号 客服热线 18720358503

技术支持:凡科建站